Ubuntu: WMWare no reconoce mis dispositivos USB

Es posible que cuando conectes un dispositivo USB a tu ordenador, este esté visible en Ubuntu pero no en la máquina virtual WMWare.

Para solucionarlo basta con editar el fichero ‘fstab’:

sudo gedit /etc/fstab

y añadir las líneas:

# USB for vmware/vbox
none /proc/bus/usb usbfs devgid=46,devmode=664 0 0

Reiniciar Ubuntu y la máquina virtual.

Asegúrate que en las propiedades de tu máquina virtual tienes activado en controlador USB.

Una vez reiniciada la máquina virtual basta con ir a VMWare y en el menú ‘WM’->Removable devices->USB Devices seleccionar el dispositivo USB que queremos activar.

Con esto debería bastar, espero que os funcione.

Sacado de la guía para instalar VMWare en Ubuntu 8.04 (en inglés).

Mi USB ha dejado de funcionar en Ubuntu – Solución

Misteriosamente hoy mi USB ha dejado de funcionar en Ubuntu. Sin duda una gran desgracia para mí ya que en mi llave USB llevo mis emails y el SVN con todos mis proyectos, amén de otros documentos importantes (ando mucho de aquí para allá y descubrí hace un tiempo que el USB era la mejor opción).

Después de investigar y volverme un poco loco he encontrado una solución que me ha funcionado a la perfección:

– He abierto una consola y he tecleado:

sudo modprobe -r ehci_hcd 

Después de eso he enchufado de nuevo el USB y mágicamente ha aparecido de nuevo.

¿Dónde he encontrado la solución? Dónde va a ser, en los foros de Ubuntu (solución para el problema con el USB).

Parece que esta solución no funciona a todo el mundo, y a algunos les funciona pero el dispositivo funciona como USB1.1 en lugar de USB2. Sin embargo, prueba a ver si tienes suerte.

También soluciona los problemas al conectar discos duros externos (me pasaba también en otro PC con un disco duro externo Lacie).