ZenCart se pasa a PHP5

Después del anuncio oficial del equipo de PHP en el que avisan que PHP4 dejará de tener soporte a finales de 2007, la gente de ZenCart ha decidido pasarse también a PHP5.

¿Qué supone esto? Por lo pronto, la versión 1.4 será incompatible con PHP4 y el requisito mínimo será usar PHP5.2. Sin embargo, la cercana versión 1.3.8 de ZenCart sí que tendrá soporte para PHP4. El soporte para la serie 1.3.x se mantendrá durante seis meses a contar desde la aparición la la versión 1.4.0. Este soporte no añadirá nuevas características al software pero al menos se irán publicando parches de seguridad y correcciones de fallo que se detecten.

¿Y qué consecuencias tiene esto para los usuarios de ZenCart? La consecuencia principal es que si no se empiezan a usar servidores con la versión adecuada de PHP en aproximadamente un año se estará usando un software sin soporte que no podrá tener ya parches de seguridad.

Puede no parecer muy preocupante ya que en la actualidad existen un increíble número de tiendas que usan la versión 1.2.5 de ZenCart sin aplicar los diferentes parches de seguridad que han aparecido. Sin embargo tener un software tan antiguo y sin parchear es un grave riesgo que puede evitarse fácilmente (no por dejar la puerta del coche abierto nos lo van a robar, pero no es nada recomendable).

Y hablando de la versión 1.2.5, han avisado que su ciclo de vida ha terminado y no va a tener soporte. Los nuevos parches de seguridad no estarán disponibles para ella.

El anuncio oficial aquí.

One thought on “ZenCart se pasa a PHP5

  1. Hola para mas informacion, acudir al foro especializado en zencart en español

    [link borrado por spam]

    a me ayudaron mucho en la instalacion de mi tienda

    un saludo
    manuel

Deja un comentario